Choose Your Background

  • Noah Bradley: A place to call Home

  • Noah Bradley: Their Mournful Tones

Unable to leave comments?

Suddenly find myself unable to leave comments at the bottom of chapters. Worked last night, doesn't work this morning, same browser.

Tried restarting browser, but that didn't fix anything.

Tabs I had open from last night still had working comment boxes (before I restarted the browser), so something on royalroadl changed between then and now.

The problem is I can't type in the comment box. It's not selectable. I click on it, and I don't get a cursor.

If I click _reply_ on someone else's comment, nothing happens. If I click that same _reply_ button again, a new comment box opens, but like the main comment box, I can't select it.

If I do that again on a different comment, a third box appears, still can't select it, but now the previous reply box is working as intended! What the heck?

Still can't type in the main comment box though.

And of course I can't open a support ticket, because the support ticket system uses the same comment box system, so I CAN'T TYPE IN THE SUPPORT BOX ABOUT THE PROBLEM.

Have tried turning adblock on in case this was some weird ad side-effect, but that didn't change anything.

Has this happened to anyone else? Firefox on Win7, everything was working perfectly up to this point.

Upon further experimentation:

The "working" reply box is only semi-working.
  • Keyboard shortcuts don't work at all.
  • Bold/italic/etc indicators don't reset. I can bold text by clicking the button, but now the bold button is 'stuck down' indicating bold, no matter what.
  • The text box doesn't scroll. Or, it DOES scroll, but there's no scrollbar on the side. I can use arrow keys to navigate up and down though.
The View Source button works, but on the main top-level comment box the OK button doesn't work so the contents can't be changed. Frustrating!
Using the source button on the first reply box, I can add text and hit OK. Now the box is selectable (as if I'd opened a second reply box). AND now the OK button works on the source popup on the top level comment box, but.... the top level comment box's contents aren't updated. So it remains unselectable. So I still can't leave top level comments.

Nope, spoke too soon. Using the source box only lets me add text if I can _already_ select the comment box (eg, having opened a second reply box). Otherwise the OK button does nothing (not even close the box), just like on the top level comment box. Frustrating.
Nope, it works for me. Did you try a different browser? Is it only Firefox? What about Google Chrome?
All I have is Firefox. Sad

In the console, it's saying that a "p is null" error is being thrown by the initContentBody function of tinymce (I assume this is the text editor script?). The script is dated back to 2016, so that didn't change overnight. So what happened?
I believe it's related to uBlock Origin.

If it's installed, even if it's turned off for royalroadl, the problem remains.

If it's completely disabled or removed from Firefox entirely, now everything works as intended.
Nope, spoke too soon again. Even with uBlock completely disabled, the comment box stopped working again.

Basically, sometimes it works on a refresh, and sometimes it DOESN'T. It makes no sense to me.

Hundreds of chapters, and I've always been able to comment just fine. Why did it stop working now?
I think it's your computer, and you honestly should try downloading a new browser and trying it there.
We are aware of an issue with adblocks interacting with the comment box and are working on a fix.

Users browsing this thread: 1 Guest(s)